1

I'm trying to switch to the Localhost 8545 network in Metamask. I'm on a Windows 10 machine with a Google Chrome browser. When I look at the settings, the "Localhost 8545" network has a gray lock on it.

Network list in metamask

When I try to switch to that network using the dropdown in the upper right corner, I can only see the "Ethereum Mainnet" and my custom network "http://localhost:7545"

Metamask network selection dropdown

When I try to manually add "Localhost 8545" by clicking on "Add Network" in the dropdown, then when I put "http://localhost:8545" in the "New RPC URL" field I get an error that says "This URL is currently used by the localhost network".

This URL is currently used by the localhost network

What should I do to switch to the Localhost 8545 network in Metamask?

1 Answer 1

4

i had the same problem. you have to got to settings, advanced options, then toggle show test networks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.