1

When I try and pipx install eth-brownie I get the following error:

PS C:\Users\karee\web3_py_simple_storage> pipx install eth-brownie
No Python at 'C:\Users\karee\AppData\Local\Programs\Python\Python310\python.exe'
Fatal error from pip prevented installation. Full pip output in file:
    C:\Users\karee\.local\pipx\logs\cmd_2021-11-15_10.52.40_pip_errors.log

Error installing eth-brownie.

I originally installed python 3.10 (on Windows). However, had issues so I deleted and installed 3.9.5. I deleted all PATH mentions of 3.10 in my environmental variables.

I'm new to coding and don't really understand PATHs well. Any help resolving this issue so I can pipx install eth-brownie would be greatly appreciated!

2 Answers 2

2

Okay, so I found a fix.

https://githubmemory.com/repo/pypa/pipx/issues/592

Basically, After installing/reinstall python, pipx got confused. I had already tried uninstalling/reinstalling pipx but it did not help.

The link above saved the day. In addition to uninstalling/reinstalling pipx, I deleted the contents of the .local file and that worked!

0

Removing .local did not work for me. However after removing C:\Users\(username)\AppData\Local\pipx, it worked! Try both.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.