10

I'm syncing my geth client with ropsten testnet and just realized how slow is the syncing process after a certain block(trying to retrieve information from blocks that got in blockchain yesterday) for a couple of hours.

Basically I got several messages like this one, saying a potential rewrite attack:

I0111 08:28:09.783928 eth/downloader/downloader.go:723] Peer 7335842dc6658f60 [hs 0.00/s, bs 0.00/s, rs 0.00/s, ss 0.00/s, miss    0, rtt 13.155759485s]: potential rewrite attack: #224778 [00000000�] <= #224778 limit

My question differs from this question as I'm not yet synced as I've checked out. One of the answers there doesn't apply here as I made sure I referenced the ropsten genesis block and checked the hash of that genesis block in my local database to certify I'm running to get in sync with the right network. So, I don't believe the cause of this high delay in my node syncing process isn't actually the addition of old morden to my local database.

Is this behavior expected when syncing? Is there any way to maximize the peer coverage to speed up the whole process if comes to that?

  • @5chdn please check my new edition, my question is similar to the one you referenced but I believe my context is different from what I've noticed as solution to that question. – Saulo Ricci Jan 11 '17 at 23:12
  • There is probably a consensus issue between the clients on testnet, that happens sometimes. – Waqar Lim Jan 12 '17 at 10:03
  • What do you get if you type eth.syncing ? – Teleporting Goat Jan 12 '17 at 13:25
  • @SauloRicci check this regarding the consensus issues on ropsten. – Waqar Lim Jan 12 '17 at 19:41
1

You can use --fast flag.The fast flag enables fast syncing through state downloads rather than downloading the full block data.

Another flag that can be used along with --fast to sync your client more quickly is --cache. The Cache flag can be used to change the default alloted memory for a fast sync.

   geth --datadir /path/to/testnet/data --networkid=3 –-syncmode=fast –-cache=1024 

Refer this :- https://medium.com/@crissimrobert/a-guide-to-ropsten-testnet-setup-f8952d615417

0

Try to add "-- fast" flag in your geth command at the time of syncing. --fast is default if you start geth the first time with no blocks downloaded. If you restart geth after initial start, --fast doesn't work anymore (it only works starting from scratch). That's why you'll have to explicitly mention it.

0

As you can see everywhere on the internet there are many issues with Geth syncing with Ropsten. I strongly recommend using Parity to sync with Ropsten network. For that I recommend following one of those links:

In addition to be easy to configure & fast to sync, Parity has a very rich command line parameters. You can check them at: https://github.com/paritytech/parity/wiki/Configuring-Parity

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.