0

I am following this tutorial to create betting app that will do transactions on basis of the results of a winner

Link to Tutorial: https://medium.com/coinmonks/tutorial-create-a-sports-betting-dapp-on-the-ethereum-blockchain-part-2-cd4753afe702

When I try to run migration i get the following error enter image description here

This is my truffle.js file

enter image description here

I have tried duplicate solutions but nothing is working for me

My versions

Truffle v5.0.2 (core: 5.0.2)

Solidity v0.5.0 (solc-js)

Node v14.15.1

2
  • Could you provide your node and truffle versions please ?
    – hroussille
    Commented Nov 8, 2021 at 8:19
  • sure Truffle v5.0.2 (core: 5.0.2) Solidity v0.5.0 (solc-js) Node v14.15.1 Commented Nov 8, 2021 at 8:20

1 Answer 1

0

You are using a truffle version that is not compatible with your node version.

Starting at 5.1.49 truffle supports node 14, prior versions such as yours may lead to very similar issues.

Upgrade truffle with this command (assuming a global install of truffle) :

npm update -g truffle
1
  • It solved my error Commented Nov 8, 2021 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.