3

I'm having some issues with my installation process for Brownie and wanted to reach out for some help. After getting pipx installed, my attempt to use 'pipx install eth-brownie' in the terminal of VSS through Git Bash received this error. Not sure how to solve this after searching online at other pages that got this error. The other stack overflow pages haven't made any sense to me. From what I understand, the LINK1120 error deals with an external symbol but I don't know what differentiates cytoolz from the other packages. Any help would be appreciated.

  
" DESKTOP-EQ4U3MP MINGW64 ~/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/Python 3.10
$ ls
'IDLE (Python 3.10 64-bit).lnk'*  'Python 3.10 (64-bit).lnk'*  'Python 3.10 Manuals (64-bit).lnk'*  'Python 3.10 Module Docs (64-bit).lnk'*  tailoredenv/
$ pipx install eth-brownie
Fatal error from pip prevented installation. Full pip output in file:
    C:\Users\yonat\.local\pipx\logs\cmd_2021-10-22_07.36.03_pip_errors.log

pip failed to build package:
    cytoolz

Some possibly relevant errors from pip install:
    build\lib.win-amd64-3.10\cytoolz\functoolz.cp310-win_amd64.pyd : fatal error LNK1120: 1 unresolved externals
    error: command 'C:\\Program Files (x86)\\Microsoft Visual Studio\\2017\\BuildTools\\VC\\Tools\\MSVC\\14.16.27023\\bin\\HostX86\\x64\\link.exe' failed with exit code 1120

Error installing eth-brownie."
5
  • Can you try following these instructions: chain.link/bootcamp/brownie-setup-instructions Oct 23 '21 at 16:39
  • Those were the instructions that I was attempting to follow but ran into some issues with. Each attempt was met with "Permission denied" or my Git freezing. To install Brownie, I just cloned the repository from GitHub. Thanks for reaching out to help!
    – user79431
    Oct 24 '21 at 20:47
  • what happens when you add sudo the the start of every command? Oct 24 '21 at 21:30
  • Truth be told, I'll probably need to backtrack further because there were more issues regarding my setup. Thanks again for offering the help!
    – user79431
    Oct 26 '21 at 0:12
  • 1
    This could also help: stackoverflow.com/questions/11094718/… Oct 26 '21 at 0:55
4

I too had this problem. I tried installing cytoolz on its own using

pip install cytoolz

but got an error as well. Found a solution by installing cython using

pip install cython

Additionally, this video has context around fixing the error.

2

use pip install eth-brownie. Using pipx wasn't working for me too!!

0

Installing cython did the trick for me! I think cytoolz is looking for it.

pip install cython
0

Had the same problem. Not sure exactly which of these steps solved the issue, but its working for me now. Uninstalled python version 3.10 and installed version 3.9.7 from the python.org webpage. Then I installed the following packages:

pip install Cython
pip install cytoolz==0.11.0

I think the version of cytoolz is important.

0

I am using macos. pip install cython worked for me. Thanks for advise

1
0

The below command solved it for me.

pip3 install --user eth-brownie

New contributor
Dhan J is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.