1

I'm trying to import "@chainlink/contracts/src/v0.6/interfaces/AggregatorV3Interface.sol" to my contract but i encountered this error. CompilerError: solc returned the following errors:

contracts/FundMe.sol:5:1: ParserError: Source "@chainlink/contracts/src/v0.6/interfaces/AggregatorV3Interface.sol" not found: File outside of allowed directories. import "@chainlink/contracts/src/v0.6/interfaces/AggregatorV3Interface.sol";

enter image description here

This is my brownie_config.yaml

enter image description here

3
  • Does this ethereum.stackexchange.com/questions/98289/… answer your question?
    – Ismael
    Oct 17 '21 at 17:25
  • Yes i checked it too, but of no use. This damn error stuck me for 4 days. I don't know how to get out it.
    – k105kad
    Oct 17 '21 at 18:08
  • Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Oct 26 '21 at 21:46
0

It turns out that in the brownie-config.yaml file, i used underscore (which is wrong) instead of a dash. correct form: brownie-config.yaml

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.