0

I'm having and issue with the "brownie compile" command.

I've copied and pasted this contract from openzeppelin following a youtube tutorial, I then right clicked on it to change the compiler version to 0.8.0 as in it's pragma but when I run the command brownie uses the 0.8.9 version and manualy changeing it from the settings doesn't work either, how can I tell brownie to use the correct version? Thanks

enter image description here

3
  • Can you copy the error message as text in the question?
    – Ismael
    Oct 16, 2021 at 19:28
  • Can you please not use screenshots? But instead copy paste the error message and all code? Oct 19, 2021 at 23:50
  • Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Oct 26, 2021 at 21:40

1 Answer 1

0

SOLVED(I'm using my newly made official account, I asked that question as a guest)

The problem was caused by me, I was importing older solidity contracts that were not on the 0.8.x version, I solved by importing an updated version of the contracts I was using

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.