1

This question already has an answer here:

my geth (geth-windows-amd64-1.5.5-ff07d548) is taking too long to sync. It has been two days and it is still not fully synced. Still missing about 600 000 blocks. Ports are opened (TCP 30303, UDP 30301), using geth.exe --cache=512 --datadir G:\Wallet\data\ and my internet connection is 6MB/s. The G: drive is internal western digital black 2TB. Windows 10 Edit: 1 block sync takes about 12min. (600 000x12=years)

marked as duplicate by Waqar Lim Jan 5 '17 at 19:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
  • 1
    I had the same exact issues. Switched the Parity and never looked back. I'm pretty sure it had to do with the spam transactions from Sept./Oct. and the subsequent Spurious Dragon hard fork. I think once you're past those, it speeds back up. Not sure what block numbers that is though. – Thomas Jay Rush Jan 5 '17 at 17:23
  • currently I am running geth --fast option, seems okay for now. If I want to use Parity (parity --geth right?), can I set the chaindata folder like with Geth? if yes, then how? – ThatGuy Jan 5 '17 at 17:44
  • No you can not use the same chaindata in parity, it will import your keys automatically though. However, if you run parity --warp you will be warped to the latest block within a few minutes. – Waqar Lim Jan 5 '17 at 19:05