3

I use web3 to send transaction with Ethereum on the ropsten network. But I tried to on main network, and I've the same result.

I don't no why but since few days send transaction function didn't work.

This is my code :

user1 = web3.eth.coinbase
user2  = 'acount2'


transaction = {'from': user2, 'to':user1, 'data': web3.toHex("test)}

transaction_hash = web3.eth.sendTransaction(transaction)

This worked but now I've this error :timeout: timed out

How can I do to resolve this?

  • This is an issue with your Ethereum node. What is the setup? Also, shouldn't user2 = web3.eth.accounts[1]? – Tjaden Hess Jan 5 '17 at 22:50
  • @TjadenHess,user2 is the account address like0x..... – wxcvbn Jan 6 '17 at 7:44
1

Most likely your (Go Ethereum, geth) node is malfunctioning or the computer running this node is under such a stress in cannot serve the requests promptly.

  • Check that the node is running, restart the node

  • Monitor your system load (available memory, CPU, use top / htop UNIX commands)

  • Restart your server

  • See from the node logs that it is following the latest block (you can get the block number from testnet.etherscan.io)

Recommended specs for the mainnet node is 4GB RAM, 100 GB HD. A testnet node can run under 2 GB RAM. Made sure you have SSD and not slow spinning hard disk, as the node will have high IO load.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.