5

I downloaded eth brownie via

pipx install eth-brownie

and got

'eth-brownie' already seems to be installed. Not modifying existing installation in 'C:\\Users\\HP\\.local\\pipx\\venvs\\eth-brownie'. Pass '--force' to force installation.

when I type Brownie for confirmation I get

'brownie' is not recognized as an internal or external command, operable program or batch file.

tried to do

C:\\Users\\HP\\.local\\pipx\\venvs\\eth-brownie --force

but got

The system cannot find the path specified.

Edit: I tried installing and reinstalling all versions of python and tried to install brownie by using

pip install eth-brownie

but it says

C1083: Cannot open include file: 'io.h': No such file or directory

I'm on windows if that makes any difference any help would be amazing thx

2

2 Answers 2

1

I have faced the same problem while running brownie. The following are the steps that helped me fix the error.

  1. First, I have uninstalled pipx and removed pipx directory from C:\Users\{Your user_name}\.local\ in which even the eth-brownie folder is located.

  2. Uninstalled Python and again reinstalled it, but this time with the custom install option as shown in the below image. Make sure you check the first option "Install for all users"

enter image description here

  1. Now just to make sure, check for python --version & pip --version. If everything is fine. Great!! Else please check if the respective PATHs are added to environment variables.

  2. Now install pipx using pip through following commands.

    • python -m pip install --user pipx
    • python -m pipx ensurepath
  3. Now make sure that pipx executable (pipx.exe) is added to the PATH in environment variables. In my case "C:\Users{Your user_name}\AppData\Roaming\Python\Python310\Scripts" which is generally where you will find it.

  4. Also make sure "c:\users{Your user_name}.local\bin" is added to the PATH, which by default gets added during pipx installation.

  5. Now try pipx --version which hopefully should give something like "1.1.0".

  6. Now install brownie using "pipx install eth-brownie"

  7. To check if everything worked, type "brownie" in the command prompt, which hopefully should give something like "Brownie v1.19.0 - Python development framework for Ethereum"

This would hopefully solve both pipx and brownie errors. Please let me know if this was helpful. Thank You!!

2
  • This actually worked thx so much!
    – AngelDev
    Jun 25, 2022 at 6:11
  • My pleasure !! @AngelDev Jul 27, 2022 at 14:27
4
+50

I faced this problem today installing brownie on friend's machine.

Problem: Was with Pipx paths used for installing/accessing brownie & python.

For some reason, even uninstalling and re-installing pipx did not change the python version/paths being used by it. Eg. We uninstalled v3.10, installed v3.9, reinstalled pipx. Pipx would still go looking for Python310.

What worked for us:

  1. We uninstalled pipx and brownie through "pip uninstall", removed all versions of Pythons we had installed (3.6, 3.9, 3.10)

  2. Reinstalled v3.9 along with system path and for all users

  3. In Control Panel, "Edit System Environment Variables", removed all non-needed python version paths

  4. Now in cmd, I would get the correct version with "python --version", however was still getting an error with "python3 --version"

  5. In the C:\Python39 directory, create a copy of python.exe and rename to python3.exe - this would stop any error with using "python3"

  6. Installed brownie using

     pip install eth-brownie
    

Brownie worked just fine after that. Pipx is still giving a hard time though.

4
  • Any chance you have a way to solve this with pipx? Nov 16, 2021 at 16:59
  • Nopes. Unable to install with 'pipx' :(
    – TS_101
    Nov 18, 2021 at 13:12
  • I'd rather see the pipx solution to this.. Any chance you can solve how to install pipx and add that as an answer here too? Nov 19, 2021 at 1:51
  • Tried this and now it shows fatal error C1083: Cannot open include file: 'io.h': No such file or directory
    – AngelDev
    Nov 26, 2021 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.