I am building a private testnet using Geth 1.5.6. I set up two nodes (miner and user) with two different datadir and listening port. Miner is a full node and mining blocks. User is just an ordinary node, syncing the blockchain and do some transactions. Both has the same custom genesis block. User connects to miner via it's enode URL.

When running in full node mode, User can connect to miner and sync the blockchain successfully. But, when I try the light client (LES) mode, miner is not responding to LES request and user is not syncing the blockchain. I am curious, how to correctly enable light server feature on miner so I can test the light client mode on private testnet? (Note: light client works flawlessly on Frontier and Ropsten).

Relevant parameters:

  • Miner: --lightserv 75 --lightpeers 100
  • User: --light
  • Enabling Topic Discovery (--v5disc) on both nodes has no effect.

1 Answer 1


You can try to create static-nodes.json file in folder ".ethereum"


And restart geth, your node will be connected now.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.