1

I'm literally just trying to create a new file in remix and it is not working. Same goes for new folder. When I try to create a new file/folder the empty bar appears for me to type in and yet I cannot type anything. No cursor shows in the bar either. If I click away from the bar or even press enter it completely disappears as if I never attempted to create a new file at all.

new file attempt

4
  • It is working now. In that situation you may try another browser chrome, brave, firefox, running in a "private" window. Also you can report to their github project github.com/ethereum/remix-project.
    – Ismael
    Sep 28, 2021 at 4:40
  • It is NOT working....I literally cannot type anything in the box to write the name of the file. If i hit any key it immediately disappears. I know I can open another browser like chrome and work from there but I want to work with Safari and remix will not let me create new files or folders on Safari. To repeat, it is NOT working. Still. Even if I just open a new window. Reboot. Nothing.
    – srg
    Sep 30, 2021 at 1:19
  • You didn't mention Safari previously, I've tested with Chrome, Firefox, Brave and I was able to create a file. As mentioned previously try reporting in remix-ide github project, they have a similar issue open for ipads github.com/ethereum/remix-project/issues/1505.
    – Ismael
    Sep 30, 2021 at 2:13
  • The same is happening to me. Were you able to resolve this? Dec 12, 2021 at 10:19

6 Answers 6

0

It did not work for me either when I used Safari. It works on Google Chrome. Hope it helps.

0

Aye, apparently there seems to be an issue with safari. Go on and try with another browser, works smoothly.

0

I had the same issue, worked after switching to the Brave browser.

0

Try it on Incognito mode on chrome. Ctrl + Shift + N

0

I did it on firefox and worked smoothly for me

0

You can click on this icon to create new file:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.