0

For a few days, I have been trying to run uniswap v3 app interface(https://app.uniswap.org/#/swap) on my local.

Reference url : https://github.com/ChainSafe/uniswap-frontend

https://github.com/Uniswap/interface

But I faced this same error.

>npm install
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: @uniswap/interface@undefined
npm ERR! Found: react@17.0.2
npm ERR! node_modules/react
npm ERR!   dev react@"^17.0.1" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer react@"^16.8.0" from @reach/dialog@0.10.5
npm ERR! node_modules/@reach/dialog
npm ERR!   dev @reach/dialog@"^0.10.3" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

It would be appreciated if anyone could fix this problem. Thanks.

2
  • What node version are you using? Can you show more of the log? the posted isn't enough to find what is failing.
    – Ismael
    Sep 23 at 5:26
  • node version is v14.15.4. Sep 23 at 23:14
0

Try using Yarn, it helped me. If not check if you have the correct node version.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.