4

I ran Ethereum Wallet for the first time on my Macbook Pro and, as it was syncing with TestNet, I selected Develop -> Start Mining. I saw the ETH balance increase steadily to 65 but then, it seemed that just when the sync completed, ETH balance went to zero, and has stayed at zero since then. I tried stopping and re-starting mining but that did not help.

Then, I noticed Develop -> Toggle Developer Tools -> Wallet UI. Clicked on that and noticed the following error in the console:

Failed to clear temp storage: It was determined that certain files are unsafe
for access within a Web application, or that too many calls are being made on file
resources. SecurityError

This seems to be related to the issue. Searching by this error message did not bring up any existing posts here, so I decided to post this question. Can anybody help throw some light on this?

Update: Just noticed that my ETH balance is now 6.88. Maybe the Javascript error can be ignored? Not sure why initially, balance was increasing in steps of 5 ether, then went to 0 and increasing very slowly now. My guess is that, by default, the syncing and mining started on the Main net and then I switched to Test net, it went back to 0. The low volume on Test net could be the reason for it taking a long time for any ETH balance to build up.

Update 2: I saw the following text today at https://github.com/ethereum/go-ethereum/wiki/Mining, which is more likely to be the correct reason of what I saw.

Note that it will happen often that you find a block yet it never makes it to the canonical chain. This means when you locally include your mined block, the current state will show the mining reward credited to your account, however, after a while, the better chain is discovered and we switch to a chain in which your block is not included and therefore no mining reward is credited. Therefore it is quite possible that as a miner monitoring their coinbase balance will find that it may fluctuate quite a bit.

I will wait for some time in case someone more knowledgeable has something more to add to this. If not, then I will convert this update to an answer.

-1

This is because Morden testnet has been decommissioned due to various stability issues.

You need to upgrade to Ropsten testnet.

https://blog.ethereum.org/2016/11/20/from-morden-to-ropsten/

  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – soc1c Dec 30 '16 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.