It's launch of Geth:

geth --testnet --fast --rpc --verbosity 0

The start of interaction with console:

geth attach ipc:/.../geth.ipc

Console works great but when I inputs the following command:

personal.unlockAccount(eth.accounts[0], "psw", 0)

(different parameters: with/without duration, "eth.coinbase" or just adress name instead of eth.accounts[0], etc)

console is blocked for several minutes. At the same time Geth does not work for all sessions, RPC is disable. Finally it returns

Error: Invalid JSON RPC response: {"error": {"EOF":"EOF", "code":-32603}, "id":11, "version":"2.0"}

Geth process is killed.

What is it?


1 Answer 1


You need to enable personal API on the command line:

   geth  --rpcapi eth,web3,personal,admin 

More info

However be aware that if you expose RPC socket to public Internet and personal API is exposed anybody can steal your Ether.

  • Also sounds like your geth instance has not synced blockchain fully yet - that might cause slowdowns on less powerful computer. Dec 26, 2016 at 16:12
  • I do not know why (all these modules were plugged) but it solved my issue. Dec 29, 2016 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.