1

I have one contract from etherscan and I'm the settings remapping one dependency on the root path that I don't own, is it possible to override it ?

  "remappings": [
    "@0x/contracts-utils=/home/cluracan/code/0x-monorepo/node_modules/@0x/contracts-utils",
    "@0x/contracts-erc20=/home/cluracan/code/0x-monorepo/node_modules/@0x/contracts-erc20"
  ],

Also , the fact i'm using brownie to test I have the following error when importing from explorer or from abi, also it looks like solc doesn't take in count the dependency I've install on my computer CompilerError: solc returned the following errors:

/home/merklejerk/code/0x-protocol/contracts/zero-ex/contracts/src/external/IFlashWallet.sol:23:1: ParserError: Source "@0x/contracts-utils/contracts/src/v06/interfaces/IOwnableV06.sol" not found: File outside of allowed directories.
import "@0x/contracts-utils/contracts/src/v06/interfaces/IOwnableV06.sol";

1 Answer 1

1

You'll need to modify the compiler config from etherscan to get it to compile. remappings needs to point to your local installations of those dependencies. I'm not familiar with brownie, but depending on what compiler abstraction you're using you will also need to make sure they're located in accessible folders (re: your last error).

2
  • thanks @lawrence I have already try to set the config on my brownie config, but still not working, /home/cluracan/code/0x-monorepo/node_modules/@0x/contracts-utils=0x/contracts-utils - /home/cluracan/code/0x-monorepo/node_modules/@0x/contracts-erc20=0x/contracts-erc20 Also I'm using sole 0.6.12 for the others contracts , it still not find the file. /home/merklejerk/code/0x-protocol/contracts/zero-ex/contracts/src/external/IFlashWallet.sol:23:1 this is not my computer Commented Sep 2, 2021 at 21:02
  • Thanks , I've solved it with remapping , the folder I've used was not accessible at the beginnig Commented Sep 3, 2021 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.