1

I have a written a smart contract in Remix. It was possible to deploy this contract on Ropsten through Remix Injected Web3, and also to interact with the smart contract through Remix. Now I am going to deploy the same contract (compiled in Remix, using the bytecode and ABI from Remix) through MyEtherWallet. I am getting the following error message:

 Invalid transaction envelope type: specified type    "0xOUT" but including maxFeePerGas and maxPriorityFeePerGas requires type: "0x2"

Other people had put the same question (same error message) on other platforms before, but were not given an answer.

1

This error is specific to MEW 6, use their older version to resolve it: https://v5.myetherwallet.com/

0

Faced the problem. But by downgrading Metamask to Version 9.8.4 it fixed my problem.

If you wish to downgrade, you can follow these steps:

  1. Uninstall Metamask. But don't forget to save the 12 words phrase first to be imported after re-installation.
  2. Download from : https://github.com/MetaMask/metamask-extension/releases
  3. Extract the zip file to a folder
  4. Find Extention / Manage Extention or type on the URL : chrome://extensions/
  5. At the top menu, click "Load Unpacked" button
  6. Navigate to the folder you make on step 3 above
  7. Older version of metamask will be installed
  8. Import phrase to get your account back

Recommended if you have wallet balance :

Before reinstalling, it's better to install the latest metamask in another browser with the same pharse. Make sure your wallet balance is the same amount. This is only for security in case of unexpected problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.