2

I am trying to get Swarm to run properly on my machine. I followed the instructions mentioned here and also saw this SE question, but couldn't get it to run with the necessary parameters. I'm stuck at this point :

nohup geth --datadir $DATADIR \
       --unlock 0 \
       --password <(echo -n "MYPASSWORD") \
       --verbosity 6 \
       --networkid 322 \
       --nodiscover \
       --maxpeers 0 \
        2>> $DATADIR/geth.log &

I assumed I just had to copy paste it, but it returns what appears to be an error :

nohup geth --datadir $DATADIR \
>        --unlock 0 \
>        --password <(echo -n "MYPASSWORD") \
>        --verbosity 6 \
>        --networkid 322 \
>        --nodiscover \
>        --maxpeers 0 \
>         2>> $DATADIR/geth.log &
[7] 51688

Did anyone got this output ? It looks like the process just stops.

  • 1
    Looks very good. What you see is the process identifier (pid) which geth (or nohup) was assigned to. Now continue with the tutorial. – Waqar Lim Dec 20 '16 at 10:32
  • @5chdn Thanks ! Will submit a pull request to make the docs a bit more clear. – Stanislasdrg Dec 20 '16 at 10:34
  • Good idea. And propose to remove the nohup part, that just confusing. – Waqar Lim Dec 20 '16 at 10:36
  • Yes, indeed, there is no reason to keep the process running if the terminal hangs up. – Stanislasdrg Dec 20 '16 at 10:41
1

The answer is: your output is not an error but expected behaviour.

What you see is the process identifier (pid) which geth (or nohup) was assigned to.

2

As an alternative you can try just this:

geth --datadir /path/to/datadirectory \
   --nodiscover \
   --maxpeers 0

You will see geth's output in your terminal. If you also add the --verbosity 6 flag, you will potentially see a lot of output :)


In case you are wondering, the reason that the guide is written the way it is with nohup and the output redirect etc. is that otherwise geth will block the terminal and you would have to open another terminal to start swarm. In the other terminal the variable $DATADIR would be empty and would have to be set again. This could make the guide more complicated to follow. We opted for this method because it allows the commands to be copy-pasted into a terminal.

Anyway, good luck ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.