2

I am trying to set up a private ethereum cluster in kubernetes. I have tried to use the stable deprecated helm chart, but it only works with older versions of the ethereum/client-go image. When I use version 1.9 or higher, I see in the bootnode logs the message Note: you're using cmd/bootnode, a developer tool. and the miners cannot connect to the bootnode.

Has anyone managed to make it work?

Also, reading this answer here in a related issue of stack exchange, I have tried to setup the cluster without a helm chart, following the guide described in the official docs of geth ethereum. In this case, I see that the bootnode, tries to connect to other network ids DEBUG[08-04|16:04:45.776] Ethereum handshake failed id=64454cd244abc39a conn=dyndial err="network ID mismatch: 100 (!= 818945082333)".

I have searched all over the internet but cannot find an updated guide. Any help is deeply appreciated.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.