0

I have a fully synced mainnet full node running Geth 1.10.6, and when I try to add --rpc.gascap 0 into the startup command, it starts syncing from block 0, even though it has a fully synced ledger in the datadir that it can use. I don't believe this was an issue before (1.10.2/3), but am seeing this after updating my nodes to Geth 1.10.6 this week. With the London hardfork and EIP-1559 coming with 1.10.6, is this a new expected behavior from something that changing the rpc.gascap of a node impacts?

Here is my Geth cmd that I am using for this node. The only thing I added that was different is the --rpc.gascap 0 line.

geth \
  --syncmode "fast" \
  --gcmode "full" \
  --http \
  --http.addr 0.0.0.0 \
  --http.corsdomain "*" \
  --http.api eth,web3,net \
  --http.port "8545" \
  --http.vhosts '*' \
  --maxpeers "50" \
  --ws \
  --ws.addr 0.0.0.0 \
  --ws.origins "*" \
  --ws.port "8545" \
  --metrics \
  --pprof \
  --pprof.addr 0.0.0.0 \
  --pprof.port "6060" \
  --datadir /ethereum/ \
  --cache "4096" \
  --networkid "1" \
  --mainnet \
  --verbosity "4" \
  --snapshot=false
2
  • this can't be true. gas cap has nothing to do with consensus or block processing. your geth is probably doing snap mode syncing which is new in 1.10.6
    – Nulik
    Aug 4 at 0:50
  • show us the log files where it says that it is downloading blocks from 0
    – Nulik
    Aug 4 at 0:50
0

I found my issue. We have our Geth run command inside of a configMap that gets loaded by the pod. I manually added the --rpc.gascap 0 line to the configMap, and forgot to add a \ after. The following settings were being omitted from our startup command. I think the one that was missing that was causing problems was not setting the --datadir /ethereum/ since we load our ledger backup from a different container in the pod. Leaving this question up here in case someone else runs into an issue with trying to set --rpc.gascap and needs to know a list of options that work with it.

      --metrics \
      --pprof \
      --pprof.addr 0.0.0.0 \
      --pprof.port "6060" \
      --datadir /ethereum/ \
      --cache "4096" \
      --networkid "1" \
      --mainnet \
      --verbosity "4" \
      --snapshot=false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.