0

**CMD show this error message ** Geth and python is installed. enter image description here

0

When you copy-paste Git URL, use https:// instead of ssh://

Or, alternative, add SSH key to your SSH agent, probably using command ssh-add. This really depends on course instructions and this question should be addressed to whoever is running the course, not a public forum.

1
0

You are not installing from the official repo. From the image you are installing npm install etherium/web3.js (there's a typo etherium).

The web3 project started from Ethereum organization, but it is now being developed by ChainSafe. The official readme indicates npm install web3 for installing.

npm install web3
4
  • E:\studentSample>npm install web3 up to date, audited 384 packages in 2s 53 packages are looking for funding run npm fund for details 1 low severity vulnerability Some issues need review, and may require choosing a different dependency. Run npm audit for details. Jul 29 at 18:00
  • @AmmaraDeveloper So it installed correctly. There is a low severity vulnerability, that usually shouldn't be a problem.
    – Ismael
    Jul 29 at 18:07
  • then why still I am unable to install web3.js Jul 29 at 18:20
  • @AmmaraDeveloper The message says that web3 is already installed. You should be able to use it. If you can't use web3 update the question or create a new one, after looking the site for existing answers.
    – Ismael
    Jul 29 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.