0

I am trying to create node in Private Ethereum Chain.

l have used this command for creation of Ethereum node:-

  geth --datadir="~/data/node1"  init="/Documents/PRIVATENET/genesis.json" –nodiscover --ipcdisable --networkid 100 --port 30301 --rpcport 8101 console

I have specified networkid and custom genesis file for creation in the command.But the output shows that,it directs towards the default genesis file and default network id '1'.

(Refer these lines

     I1209 13:48:24.553115 eth/backend.go:189] Protocol Versions: [63 62], Network Id: 1

     I1209 13:48:25.092896 eth/backend.go:207] WARNING: Wrote default ethereum genesis block)

This is the output :-

 I1209 13:48:24.479719 cmd/utils/flags.go:624] WARNING: No etherbase set and no accounts found as default
 I1209 13:48:24.479972 ethdb/database.go:83] Allotted 128MB cache and 1024 file handles to /home/toshiba/data/node1/geth/chaindata
 I1209 13:48:24.531343 ethdb/database.go:176] closed db:/home/toshiba/data/node1/geth/chaindata
 I1209 13:48:24.532522 node/node.go:176] instance: Geth/v1.5.4-stable-b70acf3c/linux/go1.7.3
 I1209 13:48:24.532569 ethdb/database.go:83] Allotted 128MB cache and 1024 file handles to /home/toshiba/data/node1/geth/chaindata
 I1209 13:48:24.553115 eth/backend.go:189] Protocol Versions: [63 62], Network Id: 1
 I1209 13:48:25.092896 eth/backend.go:207] WARNING: Wrote default ethereum genesis block
 I1209 13:48:25.093089 eth/backend.go:217] Chain config: {ChainID: 1 Homestead: 1150000 DAO: 1920000 DAOSupport: true EIP150: 2463000 EIP155: 2675000 EIP158: 2675000}
 I1209 13:48:25.093502 core/blockchain.go:219] Last header: #0 [d4e56740…] TD=17179869184
 I1209 13:48:25.093538 core/blockchain.go:220] Last block: #0 [d4e56740…] TD=17179869184
 I1209 13:48:25.093573 core/blockchain.go:221] Fast block: #0 [d4e56740…] TD=17179869184
 I1209 13:48:25.094619 p2p/server.go:342] Starting Server
 I1209 13:48:27.245136 p2p/discover/udp.go:227] Listening, enode://65436e03004806bd4f4fc9a131c022c32a6cd2dcdd2773a1a13e03475295fbec6913070b843e756f06d1cf2847808f02ae712aefe93a439ddaaae7bdbcaba88e@[::]:30303
 I1209 13:48:27.246387 p2p/server.go:610] Listening on [::]:30303
 I1209 13:48:27.255301 node/node.go:341] IPC endpoint opened: /home/toshiba/data/node1/geth.ipc
0

the problem is caused by genesis file in your command use init path/genesis.json not init=path/genesis.json

  • But now it exists with the following error "flag provided but not defined: -ipcdisable" – Crissi Mariam Robert Dec 9 '16 at 9:54
  • try --nodiscover not -nodiscover – Badr Bellaj Dec 9 '16 at 10:46
  • I have tried this ( geth --datadir="~/data/node1" init "/Documents/PRIVATENET/genesis.json" --nodiscover --ipcdisable --networkid 100 --port 30301 --rpcport 8101 console ) but the following error is generated "flag provided but not defined: -nodiscover" – Crissi Mariam Robert Dec 13 '16 at 3:49
  • check your init path – Badr Bellaj Dec 13 '16 at 8:55
  • path specified for genesis.json file is correct – Crissi Mariam Robert Dec 14 '16 at 4:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.