3

I have geth on an OSX retina iMac 5K and got it working and synchronized.

Tried running AlethOne and it just sits there displaying Status 11:05:57 New block#0 regardless of whether I "start mining" or not.

Tried turning geth off and ran AlethOne and got the same result.

Do I need to do something special with my router to make AlethOne synch inbound and outbound with the Ethereum network? Or do I need to install anything else? Is there a manual for AlethOne?

Thanks

3

there is an old thread from the Forum and although it relates to Alethzero the Troubleshooting section may offer a few pointers, here is an extract;-

a) I press 'Go' and nothing happens

Before anything else, keep an eye on the log window, look for error messages, but give it time! It take a good 5 minutes from the UPnP connection on my machine to start downloading blocks - and a couple of hours to catch up on the full chain.

If you're not seeing any peers after a few minutes, make sure UPnP is on on your router, and working. Check for UPnP related messages in the AlethZero log window.

If that doesn't help, the bootstrap node is sometimes down, it's expected on a testnet. The simplest way is to press 'Go' anyway (to start the network), then identify a node on https://stats.ethdev.com/ that has plenty of peers (the Go bootnodes are good for this. Click "Network > Connect to Peer" and input the IP of the node and the correct port (30303), as such: xxx:xxx:xxx:xxx:30303.

b) It's 'not working'!

First, upgrade. You might think that that version you installed last night is good enough but it's likely a new one is already out, and very often, the version number will not change after a merge from a debug branch, only the commit hash. So before trying anything else, please go through the 'upgrade' procedure described just above, and try again.

Additionally
there was a thread about a month ago on OSX build issues
relating to Unable to open Alethone and Alethzero on Mac OSX 10.9.5, a suggested solution was

brew update
brew upgrade

however the O/P has not reverted.. at this time.

  • 1
    Please don't post link-only answers. Try to add some details to your posts from the linked sources. – Waqar Lim Feb 6 '16 at 13:43
  • 1
    sorry about that.. just ran out of steam, will edit to expand.. – Donnelly Feb 6 '16 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.