3

I recently tried getting back into developing on Ethereum and it seems that everything about my setup has changed in the last half a year. I used to just be able to download a wallet from https://github.com/ethereum/mist/releases , and be able to connect to the public testnet easily. Now even the installation guide for geth tells me how to run a private testnet, but not how to connect to the public one...

So, I got my Windows geth from https://geth.ethereum.org/downloads/ . I tried running geth.exe --testnet --rpc --rpcapi "personal", but it doesn't appear to be synching with anything like it used to.

How can I connect geth to a public testnet, synch with it, get some ether to play around with and be able to connect to everything through a json rpc connection?

3
  • This is just a bad timing I think. The public testnet morden with id 2 was just reset and ropsten with id 3 introduced. Clients may not be ready, yet, to support them native, however, you can migrate manually, see for example this thread, and for mist, and one more for windows.
    – q9f
    Dec 2, 2016 at 13:57
  • 1
    Be careful using RPC with the personal API: it can allow people to brute-force your accounts. IPC is better in most cases Dec 4, 2016 at 7:40
  • @TjadenHess Can you elaborate on this? As in, how would using RPC with the personal API allow people to brute force your accounts, assuming you were running the testnet? Jun 14, 2017 at 23:36

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.