0

I am following this tutorial and am able to successfully generate the genesis file and the initialize the bootnode as well but I am unable to start the mining process. Every time I run :

    geth --datadir node1/ --syncmode full --port 30311 --rpc --rpcaddr '0.0.0.0' --rpccorsdomain '*' --rpcport 8501 --rpcapi 'personal,db,eth,net,web3,txpool,miner' --bootnodes 'enode://df1b4a467476afa30001457da3f489cb045e15a6ed5b1f172abb610fa23607f611edf1a5172c0f0be8d72626de1ed8d8fd68f41586ac410a4a1e2a5322991755@127.0.0.1:0?discport=30310' --networkid 1010 --gasprice '0' --unlock '0x2817bfe894bB0D148a5c43CCb1361f360D474bC1' --password password.txt --mine 

I get : Incorrect Usage. flag provided but not defined: -gasprice What am I missing ?

PS : The same tutorial was shown in form of a video and I don't seem to have missed any steps.

1

it is:

--miner.gasprice

if you are using geth 1.10.6

geth help 

for more info

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.