1

I am facing some errors during the installation of dependencies. whenever I run

npm install

the dependencies start downloading however after a few seconds it gives the following error shown in picture.

enter image description here

I spend a lot of time solving this issue but I am unable to solve it that's why I am here. I have also asked on many platforms but didn't get any good answers. the following is the link please if you have time check it out it's very important for me.

https://github.com/pipy/Ethereum-based-Rating-and-Review-Management-System-for-E-commerce

7
  • Are you behind a firewall? What version of node are you using? I tried with node v10.24.0 and it run npm install without issues.
    – Ismael
    Jul 23 at 16:10
  • I am using node version v14.16.0, Truffle v5.3.2 Jul 24 at 7:11
  • I tried with node v10.18.0 too still no working. same error. Jul 24 at 8:16
  • It uses an old version of web3 so I didn't try installing with node 14. It install fine here with node 10, it seems a problem with your connection, perhaps you can try with a vpn. Another alternative is try upgrading the dependencies that fails to a more recent version.
    – Ismael
    Jul 24 at 18:18
  • I am using VPN because where I am now they don't allow google services however without VPN also not working. this code is very important for me. do you have time to make changes to work for the latest version and upload it to Github because I also tried with node 10 not working? will be very thank full to you. Jul 25 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.