So I have deployed a contract to the Rinkeby testnet but I have added some new features to it and I've tried deploying the contract again but it just says the following:

√ Fetching solc version list from solc-bin. Attempt #1.

Everything is up to date, there is nothing to compile.

Network up to date. Network up to date.

I am not sure what I need to do to get the new version up and running. I have used some of the following commands:

truffle migrate --reset
truffle migrate --network rinkeby
truffle compile

And they all print the same message

1 Answer 1


So this command solved the problem apparently:

truffle migrate --reset --compile-all --network rinkeby
  • Something doesn't add up. --reset would only be needed if there is no difference between the latest bytecode and the bytecode already deployed. Or, if deploying multiple contracts and you want to start fresh. It doesn't seem to match up with "added new features" because that would result in different bytecode that the default command would deploy. Commented Jul 18, 2021 at 0:04
  • I have no idea why it didn't register changes on the contract but by using that command it deployed the new changed version. Commented Jul 18, 2021 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.