1

I call pipx install eth-brownie and get this error:

pip failed to build packages:
    bitarray
    cytoolz
    lru-dict

Some possibly relevant errors from pip install:
    fatal error: too many errors emitted, stopping now [-ferror-limit=]

Error installing eth-brownie.

I've tried googling to no avail - any advice on how to properly install eth-brownie on Mac?

Thanks!

2

2 Answers 2

1

First make sure you have Python3 installed, do a quick search for that and come back here once you have installed

First install Homebrew, if you don't have it installed yet, by typing the following in your terminal:

/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"

Then install pipx via Homebrew (that's what you just installed via "curl" command

brew install pipx

Once done installing type

pipx ensure-path

to ensure the path (duh)

Then you need to exit the terminal and open a new terminal window

exit

Open a new terminal window and run the original scrip you were failing on

pipx install eth-brownie

If successful, terminal will read:

installed package eth-brownie x.x.x, Python x.x.x
These apps are now globally available
- brownie
done!
0

Having a MacOs with M1, I had to perform those steps:

STEP1: python -m pip install --user cython
STEP2: python -m pip install --user cytoolz
STEP3: python -m pip install --user eth-brownie
STEP4: python -m pip install --user pipx
STEP5: python -m pipx ensurepath
STEP6: RESTARTED TERMINAL
STEP7: pipx install eth-brownie

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.