Just launched parity (using v.1.4.4 at the moment) as always, and when I try to access its UI (via http://localhost:8080/ ), I get this error:

404 Not Found
Your homepage is not available when Trusted Signer is disabled.

You can still access dapps by writing a correct address, though. Re-enable Signer to get your homepage back.

How can I reenable the signer? I've already tried parity signer new-token in the command line, and it gives me a new token, but I cannot do anything with that token in the 404 page, so I'm lost.


Make sure you are not running with --no-ui flag.

Geth-compatibility mode (--geth) also disables the UI by default, if you wish to use UI together with Geth-compatibility run with --geth --force-ui.

  • running --force-ui worked, I dont run geth any idea why it didnt load by default ? – NaN Sep 10 '17 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.