0

So I wrote a contract here: https://github.com/connova/CareBuds-Finance/blob/main/contracts/Buds.sol

When deploying this using the injected web3 on the binance testnet (network name BSC Testnet) using remix.ethereum.org

I get the following error:

Error Gas estimation errored with the following message (see below). The transaction execution will likely fail. Do you want to force sending? Internal JSON-RPC error. { "code": -32000, "message": "execution reverted" }

When I try force sending, it still fails.

Here is the failed transaction: https://testnet.bscscan.com/tx/0xddbe45fe933f8931efe7f355d2e9d261cdad3d9aa8383ef4129259b7609dc222

When deploying using remix I enter these parameters into the constructor:

  1. 0x53904DaebA21A10262bC460E91aA44B2608dC2BF (goodBudsWallet)
  2. 0x04650Fe3f51B1079fEC3d71b96669857dEa3bBcb (smokeOutWallet)
  3. ["0x04650Fe3f51B1079fEC3d71b96669857dEa3bBcb", "0x10d878297155226C5DbDBB19609D6553981aCc28"]

#3 is an array of team members (what I actually enter into the constructor as its third parameter when deploying). These addresses are the accounts I have created in Metamask, none of them are the accounts initiating the contract creation.

What I've tried:

  • I changed my browser from brave to chrome and had the same error.
  • [update] I removed the array input parameter in the constructor, but I still have the exact same error.
2
  • The contract uses an address from bsc chain 0x05fF2B0DB69458A0750badebc4f9e13aDd608C7F as IUniswapV2Router02 router. The address exists on testnet but it is not a IUniswapV2Router02 router and calling will fail. Look for the correct address for testnet.
    – Ismael
    Jul 1 '21 at 4:30
  • Thank you it worked! Problem solved :) Jul 1 '21 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.