I am trying to connect Ganache GUI to my WSL2 terminal in Intellij but I randomly encountered a new problem. I find that I cannot specify the hostname of the server other than - All Interfaces which doesn't work with WSL 2 terminal. I need to specifically be able to select the WSL2 hostname for it to work.

enter image description here

enter image description here

I've tried

  1. Restarting Ganache
  2. Restarting Computer
  3. Creating new Project in Ganache
  4. Restarting new Project in Ganache
  5. Uninstalling and Reinstalling Ganache

I randomly uninstalled and reinstalled a 2nd time and it seems that I can get the dropdown for all networks if I start a new project. The old project seems corrupted so I ended up deleting it and restarting my project.

I'm not sure what exactly happened.


in my case, same problem was because my ip local address was automatically changed. So, I'm turn back old configuration, and turn off automatic dhcp.


Similar to Hunab Ku I had to change my adapter IP address back to what was previously set in order to get Ganache working again.

I tried uninstalling, deleting projects, etc to no avail.

You can get the previous IP Ganache is trying to use by turning on the logging feature in the Advanced menu of the Ganache GUI. Then try to create a new project to generate a log file. Mine looked like:

[2021/08/15 08:56:28.703] - Starting server with initial configuration: 

I set my adapter back to that IP address and it worked. Looks like this issue has been logged on the Github project as well: https://github.com/trufflesuite/ganache/issues/2986?_pjax=%23repo-content-pjax-container


I find my ganache data locator this directory(mac).

/System/Volumes/Data/Users/junwang/Library/Application Support/Ganache

you can remove this Ganache directory and then Reinstalling Ganache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.