2

Reading from the Solidity release notes, for release 0.5.14 I read "Set the default EVM version to Istanbul". While for 0.8.5 I read: "Set the default EVM version to Berlin".

Does this mean that EVM before Istanbul could run contracts written in Solidity up to 0.5.13, while Istanbul supports contracts written in Solidity up to 0.8.4?

1 Answer 1

1

Yes, the EVM Istanbul release is capable of running contracts compiled with Solidity versions up to 0.8.4.

For 0.8.25, this is cancun

Solidity 0.5.14: This release set the default EVM version to Istanbul, indicating that contracts compiled with this version or earlier (up to 0.5.13) are compatible with the Istanbul EVM.

EVM Istanbul: There weren't any significant EVM version changes introduced between Istanbul and the introduction of Berlin as the default version in Solidity 0.8.5.

Therefore, the Istanbul EVM offers backward compatibility for a wide range of Solidity versions, ensuring it can run contracts compiled up to version 0.8.4.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.