1

OK firstly hello and thank you to anyone that helps me out here!

Below is the code i used to generate my token on Remix!

enter image description here

Now I am aware that the IMPORT has a version of 0.6.0 and im hoping that someone smarter than me can let me know if this effects anything. I was however able to successfully compile and deploy my token. Here is etherscan address: https://etherscan.io/address/0xdf09183bbe885af8acd42f5eff217544573393fa#code

Now I have gone through to complete my verification and have tried all the different ways to get this through without avail. I have gone with the 0.6.2 version, i have changed the version to match the import. i have tried uploading the single code option, i have tried uploading the multiple .sol option, i have tried uploading the .json file.

In most cases i receive this error: Error! Unable to generate Contract ByteCode and ABI (General Exception, unable to get compiled [bytecode])

After looking up many many forums and reading as much as i can, i have tried many different ways to upload the ABI, i have been here! https://abi.sonnguyen.ws/ and here! https://abi.hashex.org/ essentially im not sure if i need it or not. I get the error weather i upload an ABI or not, when i dont upload an ABI and i upload my single .json file i get this!!

enter image description here

Now i am aware that etherscan struggles with Import's. and i have read several things that link github links and say to use this and that. usually things like truffle or something that can "flatten". Now im a windows user, i dabbled in kali linux a while back, but anything linux wise im going to be learning from scratch. so ideally if i can solve my problem without having to download a linux machine would be great.

In short im confused and at a loss of what to do next, i need to get my token verified so i can start getting it established on some exchanges. Any more details that are required please ask. I will be heading to nappy poo in beddy bye land after posting this, so i wont reply for about 8-9 hours.

1

I'm guessing the issue might be when you are trying to verify the contracts on etherscan you are not updating the import line in token contract after adding multiple files. Make sure you have all the import files in the ERC20 dependencies ready and change the import line in the token contract to import "ERC20.sol". Now upload all these files together and use the same compiler version that you used while deploying the contract.

1
  • Often people forget to set the same optimization settings as used during deployment. Check that as well.
    – mzaidi
    Jun 16 at 6:13
0

Try this https://abi.hashex.org/#. Paste your contract abi and the parameters that you give for your constructor (if any)

1
  • as i stated in my initial comment i tried that lol, thanks though Jun 15 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.