This question was closed due to being off-topic, which is fair enough, but I'll add the solution here in case it helps someone: Change protocol to stratum1+tcp.

I have been using the ethminer client to mine on the binance ether pool.

Around 24 hours ago (16:00 EDT Jun 10th), my worker's reject rate hit 100% Hash rate and reject rate chart

Checking the pool stats at 21:00 EDT, this is what I saw: enter image description here

Seemingly indicating that there was some kind of widespread issue affecting over half of the pool.

Checking the stats now, you can see that a majority has recovered.

enter image description here

Despite this, I am still getting the issue, and can't find any information about what's going on.

After checking the ethminer output, I noticed all solutions were being rejected. I tried restarting with my usual url:

stratum+tcp://user.001:[email protected]:1800

And repeatedly got this error:

Stratum got invalid Json message : BadHexCharacter

I then tried changing the protocol to stratum2, which stopped that error, but then all solutions were still rejected.

Reject reason : Unspecified

**Rejected 72 ms. ethash.poolbinance.com []

This is the command I'm using to run ethminer:

ethminer --cu-devices 0 -P stratum2+tcp://user.001:[email protected]:1800

  • 2
    The solution was to use protocol stratum1+tcp Jun 12, 2021 at 5:17