5

I synced geth using the --fast option, and after the sync, I had a little freak-out because I had lost all my ether. Actually the problem is that although I have peers, I have not the good testnet blockchain.

I tested the following hashes :

> eth.getBlock(0).hash
"0x0cd786a2425d16f152c658316c423e6ce1181e15c3295826d7c9904cba9ce303"
> eth.getBlock(1000000).hash
"0x933de4c85a76c1b0652b01d4c22b5f66b76bd44005f607574900ab8bfd4ae052"
> eth.getBlock(1500000).hash
"0x92b43a22a1b33f69397d9fa4d54271df8217635c447f331690c8c21df53b3eab"
> eth.getBlock(1800000).hash
"0xb39e009518615dd1e792537aea755d9b83446a4c504a7df6facd48a8a9345213"

As you can see, my genesis block is correct, as well as the blocks 1000000 and 1500000, and the block 1800000 is wrong.

I tried the following command : for(i=0;i<admin.peers.length;i+=1) admin.removePeer(admin.peers[i].id)

but geth doesn't resync its blockchain.

Where can I find peers for Morden? Is there a different solution from doing removedb and sync again? I have no guarantee that it won't make a fork again!

  • So finally I did removedb, and am syncing using --fast, but this time without --cache=1024 --jitvm --jitcache=64. Hope this will work… I'll let you know! – Labo Nov 17 '16 at 7:58
  • Now I have the loop "gas used error" "Bad block #1873138" I had it on a previous server but I can't tell how I solved it – Labo Nov 17 '16 at 15:00
  • 1
    Re: gas used error: github.com/ethereum/go-ethereum/issues/3183 – Afr Nov 22 '16 at 14:40
1

The problem was that morden was running down

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.