1

I got the following error when I do cmake on cpp-ethereum.

I have libjson-rpc-cpp, curl. Even then I am getting the following error:

-- Found jsoncpp: /usr/lib/x86_64-linux-gnu/libjsoncpp.so  

-- JsonCpp headers: /usr/include/jsoncpp

-- JsonCpp lib   : /usr/lib/x86_64-linux-gnu/libjsoncpp.so

CMake Error at cmake/Findjson_rpc_cpp.cmake:105 (string):

  string sub-command REGEX, mode REPLACE needs at least 6 arguments total to
  command.

Call Stack (most recent call first):

  cmake/UseJsonRpc.cmake:4 (find_package)

  cmake/EthDependencies.cmake:203 (eth_apply)

  eth/CMakeLists.txt:7 (eth_use)


CMake Error at cmake/Findjson_rpc_cpp.cmake:106 (string):

  string sub-command REGEX, mode REPLACE needs at least 6 arguments total to
  command.

Call Stack (most recent call first):

  cmake/UseJsonRpc.cmake:4 (find_package)

  cmake/EthDependencies.cmake:203 (eth_apply)

  eth/CMakeLists.txt:7 (eth_use)


CMake Error at cmake/Findjson_rpc_cpp.cmake:107 (string):

  string sub-command REGEX, mode REPLACE needs at least 6 arguments total to
  command.

Call Stack (most recent call first):


  cmake/UseJsonRpc.cmake:4 (find_package)

  cmake/EthDependencies.cmake:203 (eth_apply)

  eth/CMakeLists.txt:7 (eth_use)


-- Could NOT find json_rpc_cpp: Found unsuitable version "..", but required is at least "0.4" (found /usr/local/include)

-- json-rpc-cpp headers: /usr/local/include

-- json-rpc-cpp lib   : /usr/local/lib/libjsonrpccpp-common.so;/usr/local/lib/libjsonrpccpp-server.so;/usr/local/lib/libjsonrpccpp-client.so

-- Found CURL: /usr/lib/x86_64-linux-gnu/libcurl.so  
-- curl headers: /usr/include

-- curl lib   : /usr/lib/x86_64-linux-gnu/libcurl.so

CMake Error at /home/iiita/cmake-3.2.2/Modules/FindBoost.cmake:1182 (message):
  Unable to find the requested Boost libraries.

  Unable to find the Boost header files.  Please set BOOST_ROOT to the root
  directory containing Boost or BOOST_INCLUDEDIR to the directory containing
  Boost's headers.

Call Stack (most recent call first):
  libdevcore/CMakeLists.txt:9 (find_package)


-- Could NOT find leveldb (missing:  LEVELDB_LIBRARY LEVELDB_INCLUDE_DIR)

CMake Error at cmake/FindPackageHandleStandardArgs.cmake:138 (message):
  Could NOT find CryptoPP (missing: CRYPTOPP_INCLUDE_DIR CRYPTOPP_LIBRARY)

  (Required is at least version "5.6.2")
Call Stack (most recent call first):
  cmake/FindPackageHandleStandardArgs.cmake:374 (_FPHSA_FAILURE_MESSAGE)

  cmake/FindCryptoPP.cmake:107 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)

  cmake/UseCryptopp.cmake:2 (find_package)

  cmake/EthDependencies.cmake:203 (eth_apply)

  libdevcrypto/CMakeLists.txt:8 (eth_use)


CMake Error: The following variables are used in this project, but they are set to NOTFOUND.

Please set them or make sure they are set and tested correctly in the CMake files:

/home/iiita/cpp-ethereum/libdevcore/Boost_INCLUDE_DIR
   used as include directory in directory /home/iiita/cpp-ethereum/libdevcore
/home/iiita/cpp-ethereum/libdevcore/LEVELDB_INCLUDE_DIR

   used as include directory in directory /home/iiita/cpp-ethereum/libdevcore
LEVELDB_LIBRARY (ADVANCED)

    linked by target "devcore" in directory /home/iiita/cpp-ethereum/libdevcore

-- Configuring incomplete, errors occurred!
See also "/home/iiita/cpp-ethereum/build/CMakeFiles/CMakeOutput.log".
  • Are you building the latest develop branch from github? Are you using a recent version of cmake? – chriseth Nov 16 '16 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.