0

For some reason, I am having a lot of weird issues with ganache at the same time and I have no idea what's causing them or even what to show to explain it.

After migration, which appears to succeed, all* of my contracts are being labeled as deployed in ganache GUI, but they aren't showing up in the transaction logs and neither are my transactions; yet, the code from contracts will still run. The migration contract's owner variable is set to the zero address and the same with the rest of the addresses in other contracts. Nothing in the state of the contracts is changing, but yet the code can talk across smart contracts despite them being listed as the zero address in the smart contract readout in Ganache GUI.

All*: The contracts also show up twice in the GUI one as not deployed and another that is for each that gets deployed.

Transactions appear to work in truffle develop, but they are always sent to null according to the log output in my tests.

The strange thing is that truffle development is giving me deployment addresses, which show up in the Ganache GUI, and transaction hashes that lead to nothing in Ganache GUI and nothing with truffle debug.

I have tried uninstalling and reinstalling; as I side note after I uninstalled and reinstalled I am still getting the same mnemonic from truffle develop every time.

0

Use ganache-cli instead of ganache-gui.//gui is not working properly few times.In addition to this,you can change the mnemonic by configuring truffle.js or truffle-config.js

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.