1

After installing python3, ganache-cli, upgrading pip to pipx and installing eth-brownie.. I am receiving errors when trying to use "brownie".

I followed all of the steps in their docs correctly and have tried the alternative ways to install it, but I can't seem to figure out why brownie is not being recognized as a module. It said it was installed globally, by the way.

These are the errors I get when trying to use the brownie command.

enter image description here

Does anyone understand what is going on? If I try using the command py -m brownie, it returns the error 'brownie' is a package and cannot be directly executed

Any help is greatly appreciated, thank you!

0

Turns out I had installed eth-brownie with both pip and pipx. This must have caused some complications when locating and trying to run the scrips. Uninstalling it from both and then reinstalling it with only pipx did the trick.

3
  • getting similar issue with macos and python3.9. tried re-install but not working. any alternatives? Sep 24 '21 at 5:33
  • I'd say try uninstalling every version of whatever software/package you are having issues with. Once you have it all uninstalled, then reinstall your desired version. This will help reset certain scripts or environment variables that may be pointing to the wrong software/version folders. Don't have too much details about your issue but I hope that helps. Sep 25 '21 at 6:38
  • I have tried to install it in virtual environment instead of installing it globally. its working fine. Sep 26 '21 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.